Problems reaching MultiNet by phone
Incident Report for MultiNet Interactive AB
Resolved
Our phone service provider has fixed the issue, and service is back to normal.
Posted Mar 13, 2024 - 09:30 CET
Identified
Our phone service provider is currently experiencing a service disruption, in turn affecting all phone calls to and from us. If you need to contact us, please use our support forms through each individual service, or use the contact form at https://www.multinet.com/en/contact/ until further notice.
Posted Mar 13, 2024 - 09:00 CET
This incident affected: Telefonväxel.