Strange e-mails sent from multinet.se e-mail addresses
Incident Report for MultiNet Interactive AB
Resolved
This incident has been resolved.
Posted Dec 02, 2021 - 11:01 CET
Investigating
We're currently investigating several strange emails sent from @multinet.se addresses.
Do not open attachments, click links or follow any instructions in these e-mails until we've investigated the issue!
Posted Dec 01, 2021 - 10:50 CET