Issues reaching the support portal
Incident Report for MultiNet Interactive AB
Resolved
The issue has been resolved. All links to the support portal through all of our services are now available again.
Posted Aug 26, 2022 - 15:24 CEST
Identified
Some links leading to our online support center are not working right now. We're working on rectifying the issue.

If you need to reach our support, please call us on +46 8 52 80 22 90, or send an email to any of the following email addresses for the respective service that you're using:

Avtalshantering: avtalshantering@multinet.freshdesk.com
EditNews: editnews@multinet.freshdesk.com
EduAdmin: eduadmin@multinet.freshdesk.com
Lega Online: legaonline@multinet.freshdesk.com
Semesterlistan: semesterlistan@multinet.freshdesk.com
Posted Aug 26, 2022 - 11:00 CEST
This incident affected: Integrations / External services (Support).