Problems reaching MultiNet by phone
Incident Report for MultiNet Interactive AB
Resolved
Our phone service provider has now fixed the issue, and service is back to normal!
Posted Oct 21, 2022 - 15:09 CEST
Identified
Our phone service provider is currently experiencing a service outage, in turn affecting all phone calls to and from us. If you need to contact us, please use our support forms through each individual service, or use the contact form at https://www.multinet.com/en/contact/ until further notice.
Posted Oct 21, 2022 - 14:00 CEST
This incident affected: Telefonväxel.